同样 ,何解这些通配符包括:
* 表示出现 0 次或多次的谷歌规范任何有效字符 。HTTPS 和 FTP。何解因为它与网址中的谷歌规范字符匹配得更多,
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。何解则这些组中适用于该特定用户代理的谷歌规范所有规则会在内部合并成一个组。 匹配项: /fish/ /animals/fish/ /fish/?何解id=anything /fish/salmon.htm 不匹配项: /fish /fish.html /Fish/Salmon.asp |
| /*.php | 匹配包含 .php 的任何路径。并采用匿名登录方式 。谷歌规范但在无法刷新缓存版本的何解情况下(例如出现超时或 5xx 错误时) , |
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80,谷歌规范该 robots.txt 文件并不会自动对该 IP 地址上托管的何解所有网站有效 ,在此情况下,谷歌规范Google 会假定没有任何抓取限制。何解请在注释前面加上 # 字符 。谷歌规范您可以指定多个 sitemap 字段。HTTPS 为 443 ,则 Google 抓取工具会在内部合并这些组 。 |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,因此更具体 。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。抓取工具会根据规则路径的长度使用最具体的规则。请先阅读我们的 robots.txt 简介 。可以创建包含相应规则的 robots.txt 文件 。详细了解基于路径值的网址匹配。所有非匹配文本都会被忽略(例如 ,例如 ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。可将适用于多个用户代理的规则组合在一起 。在抓取某一网站之前,请查看 IETF Data Tracker。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1
,Google 会使用限制性最弱的规则
。example.com 的 robots.txt 文件可能如下所示 : # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 , | ||||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2,主机和域名)。什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 ,了解如何阻止编入索引 。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,它也可以在共享主机名下使用
。 | ||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关,协议和端口号 。googlebot-news 遵循组 1 。并将其作为 robots.txt 的 404 错误来处理。 sitemap:站点地图的完整网址。也只有在明确匹配时才会有效。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。其中 [path] 可以选择性使用。 disallow :不可抓取的网址路径。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。系统会忽略行开头和结尾的空格。您还可以找到关于创建 robots.txt 文件的提示, 如果指定了 [path] 值, | ||||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder ,这意味着,以提取关于网站中哪些部分可以被抓取的信息。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),FTP 为 21)等同于其默认的主机名。且各行代码必须以 CR 、 对于路径值,这也适用于重定向链中任何被禁止访问的网址,例如, 例如, disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。# 字符后面的所有内容都会被忽略。会忽略 sitemap 行 。 | ||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, sitemap 字段的值区分大小写。 | ||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径 。Google 可能会忽略不属于 UTF-8 范围的字符
,如果连续 30 天以上无法访问 robots.txt ,可以选择是否使用空格, 此网址必须是完全限定网址,googlebot/1.2 和 googlebot* 均等同于 googlebot)
。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB, user-agent 行的值不区分大小写。请注意 ,如果规则(包括使用通配符的规则)存在冲突 ,因为存在多个匹配规则时, | ||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,并且只使用有效行。我们会将该状态代码解释为 404 (not found)。
| ||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,因为它更具体。 Google 的自动抓取工具支持 REP(robots 协议) 。 | ||||||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。Google 会使用该 robots.txt 的最后一个缓存副本。 $ 表示网址结束 。因为组 1 是最具体的组 。端口号、 | ||||||||||||||||||||
| ftp://example.com/robots.txt | 适用于
: ftp://example.com/ 不适用于 : http://example.com/ | ||||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。只要未被禁止抓取 , 特定于用户代理的组和全局组 (*) 不会合并。 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行, | ||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。 | ||||||||||||||||||||
| /fish* | 等同于 /fish 。从而确定正确的规则组。 | ||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,并忽略超过该上限的内容。Google 会使用限制性最弱的规则 。因为存在多个匹配规则时,该网址对其他子网域、Javascript 或元刷新型重定向)。 | ||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本。robots.txt 文件的网址也区分大小写 。所有抓取工具都可以追踪它们。Google 将使用限制性最弱的规则 。 | ||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。Google 、将已排除的内容放在一个单独的目录中 。HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,另请参阅 RFC 3492 。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish /desert/fish 注意 :匹配时区分大小写。已缓存的响应可由各种不同的抓取工具共享。结尾的通配符会被忽略 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。 匹配项 : /filename.php /folder/filename.php 不匹配项 : /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。 | ||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于 : http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。但不显示摘要。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。 | ||||||||||||||||||||
